Back
 Maintenance
Maintenance
 Maintenance
Maintenance
Traditional accounts provider planned outage
Completed 11 Feb at 12:00pm CET.
CeFi accounts provider
Completed
Maintenance completed
Posted
11 Feb at 12:00pm CET.
 
Started
Payments, conversions and transfers will therefore not be able to be created and funding will be delayed until the maintenance has completed.
Posted
11 Feb at 10:00am CET.
