Back
Maintenance

Banking service outage

Completed 17 May at 11:28pm CEST.

Ingester Core Notifications Web App Blockchain Client Authentication CeFi accounts provider
Completed

Maintenance completed

Posted 17 May at 11:28pm CEST.
Started

All banking features are unavailable right now

Posted 17 May at 07:00pm CEST.